Upgrade

Discover how to upgrade your various versions of OpenBD between versions.

from 1.4 to 2.0

From a CFML point of view there are no changes to code required. All functions/tags work as expected.

It is advised to completely replace all your JAR files in the standard /WEB-INF/lib/ location with all the JAR files shipped with standard WAR release. If you were using the SpreadSheet Plugin, CronTab PlugIn or CFSMTP PlugIn in 1.4 you no longer need to include these JAR files. These are part of the core build.

If you were using the MongoDB CFC from 1.4 then you can continue to do so. However, you do not need to include the JAR file as this is now included in the core build along with specific MongoDB functions.

Many 3rd party JARs got updated with this release, so please start fresh, and if you are using any custom JAR files then copy them back in again.